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Introduction

Welcome to Gradekeeper!

Gradekeeper is a powerful tool for managing your gradebook. With Gradekeeper you can:

• Have 250 students per class
• Have 150 assignments per term
• Group assignments into 10 categories
• Excuse individual assignments for any student
• Drop the "worst" score in one or more categories
• Compute grades based on total points or category weights
• Assign letter grades based on your own letter grade cutoffs
• Have final exams contribute to term, semester, or final grades
• Keep every score and assignment for the entire school year
• Divide your school year into two, three, four, or six terms

Gradekeeper is very easy to use. The default options allow you to enter students, assignments, and
scores immediately. Setting up your own categories, letter grade cutoffs, and grading options is as
easy as clicking your mouse.

Getting Started

Creating a new class with Gradekeeper takes only a few minutes. When you double click the
Gradekeeper icon, the program will create a new class. Before you enter any students or
assignments, you should take a moment to set up a few things. Keep in mind that you can change
these options at any time.

Click the first item in the upper left part of the gradebook grid and type your school name, hit return
and type the name of this class, then hit return and enter your name. Hit return again.

Choose Gradebook Options from the Gradebook menu.

Click the School Year tab. Your school year options determine the number of terms in your school
year, when each term begins and ends, and which days of the week are included in the attendance
grid.

Use the pop-up menu to choose the number of terms in your school year. Gradekeeper will estimate
the starting and ending dates of each term. Adjust these dates as needed. Use the tab key to move
from item to item. Click the check boxes for each day of the week you want in your attendance grid.

Click the Categories tab. Your assignment categories help you organize your assignments. If you
compute grades using category weights, your category weights will determine how much various
assignments will contribute to the term grade. If you compute grades using total points earned, your
category weights will be ignored.



New classes start with two categories: Tests and Homework. You can change these or add your own
categories and weights. Choose to compute grades using total points earned or using category
weights. Use the tab key to move from item to item.

Click the Grading tab. Choose to round to the nearest whole percent or to the nearest tenth of a
percent. You can also drop the worst score in one or more categories.

If you give final exams, you can choose what percent your exams will contribute to the term,
semester, or final grade for the year. If you do not give final exams, these options are ignored.

Click the Letter Grades tab. Your letter grade cutoffs determine how percents are converted into letter
grades. You can leave an item blank if you do not use that letter grade. Use the tab key to move from
item to item.

Click the Scores tab. Enter the special scores you use for things like excused assignments. Use the
tab key to move from item to item. Use the pop-up menus to choose whether each special score will
be excused or count as zero points. Click OK when you are done.

Click the Attendance tab. Type in each code you use to record attendance. Use the tab key to move
from item to item. Use the pop-up menus to choose whether each code will contribute to the total
number of tardies or absences or if it will be excused.

Click OK when you are done setting up your gradebook options.

Now you are ready to enter your students and assignments. To enter students into your gradebook,
click the student column in the first blank row of your gradebook. Enter each student name then hit
the return key. It is usually best to enter your student names last name first. Hit the esc key when you
are done.

To enter an assignment into your gradebook, click the top portion of the first blank column in your
gradebook. Enter your assignment name, category, and points possible. Hit the return key after each
item. Next, enter a score for each student. Hit the return key after each item. Hit the esc key when
you are done.

When you are done entering your students and assignments, you should save your class. Choose
Save As from the File menu. Enter the name of your class. Then click the Save button.

If you have other subjects with the same students, you can use Save As to avoid entering student
names repeatedly. Choose Save As from the File menu and save a copy of your original class under
another name. Do this once for each additional class.



The Gradebook

When you create a new class or open an existing one, Gradekeeper will display the gradebook for
that class. Students are listed along the left side. You may choose to show student names, IDs, or
both. Assignment names, dates, categories, and points possible are listed along the top. Scores are
on the lower right.

Use the scroll bars to see other students or assignments in the gradebook.

To change your school name, class name, teacher name, or to edit students, assignment names,
dates, categories, points possible, or scores, first choose Gradebook from the Reports menu. Then:

• Click on the item you want to change
• Type in the new text or edit the existing text
• Press return to accept your changes or esc to cancel

Leave a score blank to indicate a missing assignment. Enter "exc" to excuse an assignment. Enter
"inc" to mark an assignment as incomplete. Enter "abs" to indicate a student was absent for an
assignment. In your gradebook options, you can choose whether these special scores will count as 0
or as excused.



When you are editing a category name, Gradekeeper will predict the category name as you type it.
You may have only one final exam in any term.

You may also use the arrow keys or the tab key to accept your changes and move to another item.

Adding Students or Assignments

To add one or more new students to the gradebook:

• Click the student name field in an empty row
• Type a name for each new student and press the return key
• Press the esc key when you are done entering names

It is usually best to enter student names last name first. You may sort students by name, by ID, or by
term grade. To sort students, choose the appropriate sort command from the Edit menu.

You can generate random IDs for your students. First, enter an ID in the desired format for the first
student. For example, if you want 5 digit IDs, enter 12345, or, if you want 3 lower case letters followed
by 3 digits separated by a dash, enter abc-123. Then choose Generate Random IDs from the Edit
menu.

You may want to excuse all assignments for any students added to an existing class. Enter "exc" for
the student’s first score, then choose Fill Across from the Edit menu. This will make every score in
that row equal to the one you are entering.

To add a new assignment to the gradebook:

• Click the assignment name field in an empty column
• Enter the name, category, and points possible for the assignment
• Enter a score for each student in the class (use "exc" to excuse an assignment)

Scores must be decimal numbers, decimal percents, or letter grades. Leave a score blank for a
missing assignment. Enter "exc" to excuse an assignment. Enter "abs" if a student is absent (this is
the same as excusing that assignment). Or enter "inc" for an incomplete assignment (this is the same
as giving a score of 0 on that assignment).

If most of the scores you are entering are the same, type the first score (but do not hit return) and
then choose Fill Down from the Edit menu. This will copy the score you just entered to all of the
scores below that one.

Extra Credit Assignments

Gradekeeper provides several ways to give students extra credit.

To give a student extra credit you can give that student more points than the points possible for an
assignment, or you can create an extra credit assignment with 0 points possible. You can also create
an assignment and place it into the Extra Credit category. See the section on grade computation for
more details about how each of these methods of offering extra credit will affect student grades.



Moving Students or Assignments

You can move students and assignments within the gradebook by dragging them:

• Click the number of the student or assignment you want to move
• Hold the mouse button down and drag to the new location
• Release the mouse button to move the item

You can use Cut and Paste to move a student into another class, or to move an assignment into
another term. To move a student into another class:

• Click the row number of that student
• Use Cut to remove the student from the class
• Open the other class (saving changes to the first class)
• Select the row where you want to insert the student
• Use Paste to insert the student into the new class

You should be careful when moving students into another class, as scores for the student you moved
may not exactly match the assignments in the new class. Gradekeeper will attempt to warn you when
this happens.

To move an assignment into another term:

• Click the column number of that assignment
• Use Cut to remove the assignment from the term
• Choose another term from the Gradebook menu
• Select the column where you want to insert the assignment
• Use Paste to insert the assignment into the new term

Dropping Students or Assignments

To completely remove a student or assignment from the gradebook:

• Click the number for that student or assignment
• Choose Cut from the Edit menu

To drop a student from your class without removing them from the gradebook:

• Click the number for that student
• Drag that student apart from the rest of your students

Students in any row after the first blank row in the gradebook are considered dropped. Grades are not
computed for these students and they are not included in any reports.



Adding Final Exams to the Gradebook

To add a final exam to the gradebook, use the "Final Exams" category. You may have more than one
final exam in a term. When there is more than one final exam in a term, the total points earned and
total points possible are used when computing grades. All semester exams should be placed in the
last term of the semester. Year-end exams should be placed in the last term of the school year.

The Attendance Grid

The attendance grid allows you to record attendance information for the entire school year. Students
are listed along the left side. You may choose to list student names, IDs, or both. Dates in the current
term are listed along the top. Attendance information is displayed on the lower right.

Use the scroll bars to see other students or dates.

To change attendance information, click the item you want to change. Enter the attendance code you
want. Gradekeeper will predict the attendance code as you type. You can print the attendance for a
single day by clicking once on the column number for that day and choosing Print from the File menu.

You can change a date to a non-school day by clicking the date. You can change a non-school day
back to a school day by clicking the date again. You can choose to hide non-school days by choosing
Hide Non-School Days from the Gradebook menu.



The Seating Chart

The seating chart allows you to easily assign students to seats. You can also take attendance for the
current date. To take attendance, control click on a student’s seat and choose the attendance code
you want from the menu that appears. You can also hide seats or mark seats as unavailable by right
clicking an empty seat and choosing the option you want from the menu that appears.

To move a student within the current seating chart, click and drag the student name to a new seat. If
there is already a student in the new seat, those students will exchange seats.



To assign all students to new seats, choose Assign Seats from the Reports menu. The assign seats
dialog will appear:

Enter the number of rows and columns in your seating chart. If you are setting up your seating chart
for the first time, you may not want to assign your students to seats immediately. Uncheck Assign
students to seats and click OK. This will allow you to adjust your seating arrangement by hiding seats
or marking some seats as unavailable.

If you do want to assign all your students to new seats, check Assign students to seats, and choose
how you want to assign seats to your students. You can assign students to seats randomly or
alphabetically by last name. Click OK to assign all students to new seats using the chosen method.



Viewing Reports

Gradekeeper can also display a variety of reports.

The class grades report shows every student’s grade for each term in the current semester or school
year, as appropriate. It also includes the semester grade and the final grade for the year, when those
when those options are chosen in Report Options.

Averages for the class and a breakdown by letter grade are also provided.



The attendance totals report gives a detailed summary of attendance for the entire class. It shows a
breakdown by attendance code for each student in the class for the current term.

The attendance summary report shows the total number of tardies and absences for each student for
each term in the current semester or year, as appropriate. Semester and year totals are included
when those options are chosen in Report Options.



The student attendance report is a complete summary of a student’s attendance. It lists all absences
and tardies for each student.

The missing assignments report is a summary of which assignments each student has not completed.
It lists each missing assignment, its category, and its points possible. Extra credit assignments are
not considered missing.



The student scores report is a complete report of a student’s performance. It lists every assignment
with its name, date, category, points possible, and that student’s score. Also included is a summary of
the student’s performance by category and by term.



The student summary report is a summary of a student’s performance. It includes a summary by
assignment category, a summary by term in the school year, and global and student comments.



The assignment scores report lists the score and percent correct of every student on every
assignment. It shows the assignment name, date, category, and points possible. It also shows the
average score for the class and a breakdown by letter grade.



The multiple class report is a single report summarizing grades for several classes. It is especially
useful for elementary teachers who teach more than one subject in their classroom. To insure that
students are properly matched, it is important to use exactly the same student names for the same
student in each class. Do not use nicknames or middle initials in one class and not in another.

The multiple class report can also include student comments, missing assignments, and a signature
line. You can use Report Options to choose which of these to include in your multiple class report.
You cannot include both student comments and missing assignments in the same report.

The multiple class report is always one page per student. Only those student comments or missing
assignments that will fit on that single page will be included. Student comments are only included for
a class when the option to show student comments was chosen in that class.

To see one of these reports, choose it from the Reports menu.

To create a multiple class report, you must choose the classes to include in the report. When the file
selection dialog appears, select the first class to include, then hold down the shift key and select the
other classes to include.

You can use the scroll bar to scroll through any report. In the student scores report, the multiple class
report, and the assignment scores report you can jump to a particular student or assignment. Right
click in the report window and choose the student or assignment you want from the pop-up menu.



Report Options

Gradekeeper also allows you to determine how reports are displayed and printed.

For the class grades report, you may choose whether to include the semester grade and final grade
for the year. You may also choose to include a breakdown by letter grade of how the class did during
the current term.

For the student scores report, you may choose whether to include a summary of each student’s
performance by category and by term in the school year. You may choose to show assignments by
category. You may choose whether to include attendance information. You may also choose whether
to include a parent signature line.

For the assignment scores report, you may choose whether to include a breakdown by letter grade of
how the class did on this assignment. For the missing assignments report, you may choose whether
to include all students, whether or not they are missing any assignments.

To set your report options, choose Report Options from the Reports menu.

Click the check box for each item you would like to include in the specified report. Click OK to accept
your changes. Click Cancel to dismiss the dialog without making any changes.



Adding Comments

You can add individual student comments for each student to the student scores report. To add
student comments, choose Edit Student Comments from the Edit menu:

For each student comment you want to write, choose the student from the combo box and enter the
comment. You can choose to show student comments or leave them private. You can also choose to
copy this comment into future terms in the school year. Click Done when you are finished. Comments
can be up to 254 characters long.



To add global comments to the student scores report, choose Edit Global Comments from the Edit
menu:

You can enter a comment that will appear before each student comment and another comment that
will appear after each student comment. Global comments are always shown on the student scores
report, even when individual student comments are not shown. You can also choose to copy these
comments into future terms in the school year. Click OK to accept your comments, or click Cancel to
dismiss the dialog without saving your changes. Each comment can be up to 254 characters long.



You can enter comments that will appear before each student comment and comments that will
appear after each student comment. Global comments are always shown on the student scores
report, even when student comments are not. Click OK to accept your comments, or click Cancel to
dismiss the dialog without saving your changes. Each comment can be up to 254 characters long.

Adding Footnotes

You can add a footnote to any score. To add a footnote, right click on the score and choose the
footnote you want from the pop-up menu. There are 8 footnotes to choose from. You can edit the text
for your footnotes by choosing Edit Footnotes from the Edit menu. The footnotes dialog will appear:

Type in the text for each footnote you want to use. Click OK to accept your changes. Click Cancel to
dismiss the dialog without making any changes.

Footnotes appear on the student scores and assignments scores reports and on individual student
web pages created by Gradekeeper. The footnote number appears in brackets to the left of the score
it applies to.



Printing Reports

To print the gradebook, attendance, or a report, choose that view from the Reports menu and choose
Print from the File menu. The print job dialog will appear. Your print job dialog may appear different
depending on the printer you use.

To print the student scores or student attendance report for a single student, or to print the
assignment scores report for a single assignment, right click in the report window and choose print.
The first and last pages will be set correctly in the print dialog. Click OK.

To print only certain pages of a report, enter the first and last page numbers in the appropriate fields
of the dialog. The gradebook and reports are displayed exactly as they will be printed

If your printer supports scaling, you can print more text on each page. Click Properties and choose a
smaller scale factor. The scale factor item may appear in other locations for some printers. Some
printers do not support scaling.

To print the attendance for a single day, choose Attendance from the Reports menu, click once on the
column number for the day you want to select it, then choose Print from the File menu.



School Year Options

You may divide your school year into two, three, four, or six terms, choose a name for each term, and
choose the starting and ending date for each term. You may also choose which days of the week to
include in the attendance grid.

To set up your school year, choose Gradebook Options from the Gradebook menu and click the
School Year tab. The school year options panel will be displayed, showing the number of terms in the
school year and the starting and ending dates of each term.

Choose the number of terms in your school year from the pop-up menu. Gradekeeper will estimate
what the first and last day of each term will be. Enter a name for each term. Enter the starting and
ending dates for each term, as necessary. Click the check boxes for the days you want included in
your attendance grid. Click OK to accept your changes. Click Cancel to dismiss the dialog without
making any changes.



Assignment Categories

Each assignment must be placed into one of ten categories. You may use these categories to
compute student grades or simply to organize your assignments. You may have different category
names and weights each term.

New classes begin with "Tests" and "Homework" categories. To change these categories, choose
Gradebook Options from the Gradebook menu and click the Categories tab. The categories panel will
be displayed, showing the current category names and weights.

Type a name and weight for each category. Use the tab key to move from item to item. You may
choose to compute grades using category weights or using total points earned. Click OK to accept
your changes. Click Cancel to dismiss the dialog without making any changes.

Category weights must be between 0 and 100. Enter a weight of NG to indicate that assignments in
that category should not be included in grade computation. You may have different categories and
weights for each term in the school year. This allows you to change how you compute grades during
the course of the year.



Grading Options

Gradekeeper gives you a variety of grading options. You may choose to have final exams contribute
to the term grade, the semester grade, or the final grade for the year. You may choose to round to the
nearest whole percent or to the nearest tenth of a percent. You may also choose to drop the worst
score from each of your categories (this does not change the score itself).

To set your grading options, choose Gradebook Options from the Gradebook menu and click the
Grading tab.

Choose the options you want, then click OK to accept your changes, or click Cancel to dismiss the
dialog without making any changes.

Exam options are only used when there are final exams. If you choose to have final exams contribute
20% of the semester grade, but do not give a final exam 1st semester, that semester grade will not be
affected. If you do not give final exams, you may ignore the exam options altogether. You may
choose different grading options for each term in the school year, but exam options apply to the entire
school year.



Letter Grades

Your letter grade options determine how percents are translated into grades. To change your letter
grade options, choose Gradebook Options from the Gradebook menu and click the Letter Grades tab.
The letter grades panel will be displayed, showing the current letter grade cutoffs.

Enter your grades and the percent required to earn each grade. You may use the buttons on the right
to choose the standard A - F system, the pass - fail system, or the outstanding - satisfactory -
unsatisfactory system.

Use the tab key to move from item to item. Each percent must be a decimal number from 0 to 120. If
you do not use a certain grade (if you do not give A+ grades), leave the grade and the percent blank.
Click OK to accept your changes. Click Cancel to dismiss the dialog without making any changes.

Letter grade options affect grades for every term in the school year.



Special Scores

You can change the default special scores, change their meanings, or add special scores of your
own. To change your special scores, choose Gradebook Options from the Gradebook menu and click
the Scores tab. The special scores panel will be displayed, showing your current special scores.

Enter a score and choose its definition. You can choose to have a special score count as 0 points, as
an excused assignment, or as a pending assignment (excused, but still considered missing). Use the
tab key to move from item to item. Click OK to accept your changes. Click Cancel to dismiss the
dialog without making any changes.



Attendance Codes

You may define the codes you use to record attendance. You may also choose whether each
attendance code will contribute to the total number of absences or tardies. To define your attendance
codes, choose Gradebook Options from the Gradebook menu, then click the Attendance tab. The
attendance panel will be displayed, showing your current attendance codes.

Enter a code and choose a category for each attendance code you use. Use the tab key to move
from item to item. Click OK to accept your changes. Click Cancel to dismiss the dialog without making
any changes.

The possible attendance categories are: Tardy, Excused, Full Absence, and Half Absence. The
excused category indicates either an excused tardy or an excused absence. Excused codes are not
included in the total number of tardies or absences.



Assigning a Password

You may assign a password to a class to prevent anyone else from opening the class. To assign a
password to a class, choose Gradebook Password from the Gradebook menu:

Enter the current password for the class. If you have not assigned a password to this class, leave this
item blank. Enter your new password, then enter your new password again to verify that you typed it
correctly. Passwords can be from 1 to 15 characters long and are case sensitive.

You should write your password down and keep it in a safe place. If you ever forget your password,
you can use your registration code instead. You must be using a registered copy of Gradekeeper to
assign a password to a class.

Assigning a password to a class only prevents others from opening the class. It will not prevent
someone from deleting the class. To fully protect your classes, you should consider using software
that limits access to your computer. You should also always keep a current backup of your classes on
another disk.

Moving Into Another Term

To move into another term, select the term you want from the Gradebook menu. All scores and
assignments are saved for the entire school year. This makes it easy for you to deal with incompletes
or correct mistakes.

When you move into a particular term in the school year for the first time, your categories and grading
options will be copied into that term.



Importing Students and Assignments

To read a list of students or assignments and scores from a text file, choose Import from the File
menu. The import dialog box will appear.

Click the check box for each item you would like to import. Choose the format for this import. You can
choose to import tab delimited text, quote comma format, or comma separated values.

You may import students, assignments, and scores into an empty class, or you may import additional
students and scores or additional assignments and scores into an existing class. Click Import to
continue. Click Cancel to dismiss the dialog without importing anything.

The open dialog will appear, allowing you to choose which text file to read this information from. The
students will be added to the gradebook after any students already in the class.



If you are importing student IDs and names, your text file should be formatted as follows:

id name
id        name
id name

New students are added after the last existing student, but before any dropped students remaining in
the gradebook. New assignments are added after any existing assignments.

If you are importing assignments and scores, your text file should be formatted as follows:

assignment assignment … assignment
category category … category
points points … points
score score … score
score score … score
score score … score

All students must be included, even if they have no scores for any assignment. Student scores must
be in the same order as those students appear in your gradebook.

If you are importing dates and attendance, your text file should be formatted as follows:

date code date code
date code date code
date code date code

You only need to include the dates when a student is absent or tardy. Different students can have
different numbers of dates. All students must be included, even if they have no absences or tardies.
Student attendance codes must be in the same order as those students appear in your gradebook.

When importing tab delimited text, items should be separated by tabs. For quote comma format,
items should be enclosed in quotes and separated by commas. For comma separated values, items
should be separated by commas and enclosed in quotes only if the item includes a comma (as when
student names are last name first) or a double quote. Do not include spaces between items.

If you are unsure about how imported text should be formatted, create a simple class and export to
text choosing the same items and using the same format.



Exporting Students and Assignments

To write a list of students, assignments, scores, attendance information, and/or grades to a text file,
choose Export to Text from the File menu. The export dialog box will appear.

Click the check box for each item you would like to export. Choose the format for this export. You can
choose to export to tab delimited text, quote comma format, or comma separated values.

Click Export to continue, or click Cancel to dismiss the dialog without exporting anything.



You may only export exam grades when there is an exam in the current term. You may only export
semester grades when you are in the last term of the semester. You may only export end-of-year
grades when you are in the last term of the year.

Click Export to continue.

The save dialog will appear, allowing you to specify the name and location of the text file which will be
created. Type in a file name and click Save.

If you are exporting student IDs and names, your text file will be formatted as follows:

id name
id name
id name

If you are exporting assignments and scores, your text file will be formatted as follows:

assignment assignment … assignment
category category … category
points points … points
score score … score
score score … score
score score … score

If you are exporting dates and attendance, your text file will be formatted as follows:

date code date code
date code date code
date code date code

Only those dates when a student is absent or tardy will be included, but all students will be included.

When exporting tab delimited text, items will be separated by tabs. For quote comma format, items
will be enclosed in quotes and separated by commas. For comma separated values, items will be
separated by commas and enclosed in quotes only if the item includes a comma (as when student
names are last name first) or a double quote.



Form Letters and Custom Reports

You can use the Export to Text capability of Gradekeeper together with the mail merge capability of
Microsoft Word to create custom form letters or reports.

First, export the items you want in your report from Gradekeeper:

• Choose Export to Text from the File menu
• Choose the items you want in your report
• Click the Export button
• Choose a name for the text file
• Click the Save button

Next, start Microsoft Word. Choose Mail Merge from the Tools menu. The Mail Merge Helper will
appear:



In the Main Document section, click Create and choose Form Letters. You can choose to use the
active window or to create a new main document.

In the Data Source section, click Get Data and choose Header Options. In the Header Options
window, click the Create button. The Create Header Source window will appear:

Click Remove Field Name until all of the default field names have been removed. Then enter the field
names you want. Your field names must match the items you exported from Gradekeeper and must
be in the same order that Gradekeeper has them. Click OK when you finish entering your field
names. The standard save dialog will appear. Choose a name for your header source document and
click Save.

In the Mail Merge Helper, in the Data Source section, click Get Data. Choose Open Data Source. The
standard open dialog will appear. Choose to show files of type text and choose the text file you
exported from Gradekeeper.



After you choose your text file, the Header Record Delimiters window will appear:

Choose tab as the field delimiter and choose enter as the record delimiter, then click OK.

You can now type your form letter. To insert one of the items you exported, choose it from the Insert
Merge Field button in the toolbar.

When you are done typing your form letter, it may look like this:

You can now create a merged document by clicking the Merge button in the toolbar:



You can also send your merged document by email. An email account and SMTP server must be set
up in Microsoft Outlook. And you need to add a column to the text file exported from Gradekeeper
that has the email addresses you want to send the report to.

Once you create a mail merge document, you can use the same mail merge document many times.
Simply change the data source to the text file you exported from Gradekeeper, and create a new
merged document.



Creating a Web Site

To allow students and parents to access grades on the internet, choose Export to Web from the File
menu. The export to web dialog will appear:

You can create a single web page or a complete web site. Choose the option you want and click OK.
If you are creating a single web page, the save dialog will appear. Enter a name for the web page you
are creating and choose where you want to save it.

When you export to web while viewing a multiple class report, a web site will be created with a web
page for each student linking to a web page for each subject, showing assignments for that student in
that class.

If you are creating a complete web site, the choose folder dialog will appear:



Choose a folder for your web site. To create a new folder, choose the folder you want to create that
new folder in (or the desktop), then click New Folder, then type a name for the new folder. Click OK
when you have chosen a folder.

When you create a single web page, student ID codes will be displayed with student grades and
attendance totals according to your current report options:

When you create a complete web site, an authorization web page will be created to ask for a student
name and ID code:

The authorization web page requires a browser that supports Javascript. Browsers without Javascript
enabled will not be able to see student web pages. The authorization web page is named index.html
by default. Most web servers use this as their default web page name. If your web server uses a
different default name (some servers use Default.html) you should rename it. If this web page does
not have the correct default web page name for your server, it is relatively easy to bypass the
authorization scheme!



If a valid student name and ID code are entered, the corresponding student web page will be
displayed:

After your web page or web site has been created, you must upload it to a web server and tell
students and parents the URL so they can access it. Your school may have a web site where you
could upload these web pages, or you can use your own web site.



To upload these web pages to your web site, you will need to use an FTP application. FTP Explorer is
an FTP application for Windows. They offer free licenses to educational users. You can learn more
about FTP Explorer at:

http://www.ftpx.com/

You can download FTP Explorer from:

ftp://ftp.ftpx.com/pub/ftpx/ftpx1010.zip

Before using FTP Explorer, you will need to know the address to connect to (it is usually not the same
address you use to access the web pages), your username, and your password. For example, if you
were using Geocities, you would connect to ftp.geocities.com using your username and password.

When you start FTP Explorer, you will see the connection dialog:

Enter your host address, login username, and password. You can enter a profile name so FTP
Explorer will save this login information. You may need to enter an initial path. Do not change the
other items. Click Connect.



FTP Explorer will connect to your FTP server using your username and password. You will see a list
of files in your directory:

Rather than upload each individual web page (which would be very time consuming), you can upload
the entire folder that Gradekeeper created, and let FTP Explorer take care of the rest. Locate the
folder that Gradekeeper created and drag it into the directory listing (but not onto another folder). FTP
Explorer will upload the folder and all its contents to your web site.

You should always try accessing your grade web site using your own web browser to make sure
everything is exactly the way you expect. The address of your web folder should be something like:

http://www.geocities.com/dethier/grades/

You should not need to specify index.html when accessing your grades web site. If you do not specify
it and you get a list of the contents of the folder instead of the login web page, you either did not
upload the index.html web page, or your web server uses a different name for its default web page.
You will need to rename index.html to the file name your web server uses.



Posting Grades Online Using Edline

Edline is a leading web publishing provider for K-12 schools. Edline makes it easy for your school to
provide parents with secure online access to grades and other information. Gradekeeper works with
Edline to post grades online quickly and easily.

To post grades online using Edline, Choose Export to Edline from the File menu. The Export to Edline
dialog will appear:

Enter the class ID for this class, then click OK. Your web browser will open a web page where you
can enter your username and password. Your progress reports will then be uploaded. Allow the
upload to complete. Parents and students can then access all their grades using their own username
and password.

Students must have an ID to be included in the export to Edline.

Your school must have an account with Edline to post grades there. If your school has an account
with Edline, ask your technology coordinator for activation instructions. If your school does not have
an account with Edline, visit http://www.edline.com/gradekeeper/gkindex.html for more information.



Posting Grades Online Using Online Grades

Online Grades is a web-based grade posting system, allowing teachers to post grades online, and
allowing parents and students to view grades online. Online Grades is open source project, so your
school can download and install Online Grades on their web server at no cost.

To post grades using Online Grades, choose Export to Online Grades from the File menu. The Export
to Online Grades dialog will appear:

Enter your class code, section, username, and password, then click OK. The standard save dialog
will appear. Choose where you want to save the XML file and click Save. This will create an XML file
that you can then upload to Online Grades.

Students must have an ID to be included in the export to Online Grades.

Your school must have an Online Grades server for you to export to Online Grades. You can visit
http://onlinegrades.sourceforge.net for more information about Online Grades.



Posting Grades Online Using School Center

School Center was created to help meet the web hosting needs of schools, administrators, teachers,
students, and staff. School Center makes it easy for schools to provide a functional, easy to maintain
web site, whether they want a simple site or a total web presence.

To post grades online using School Center, Choose Export to School Center from the File menu. The
Export to School Center dialog will appear.

Enter the class ID for this class, then click OK. The standard save dialog will appear. Choose where
you want to save the XML file and click Save. This will create an XML file that you can then upload to
School Center.

Students must have an ID to be included in the export to School Center.

Your school must have an account with School Center to post grades there. If your school has an
account with School Center, ask your technology coordinator for instructions. If your school does not
have an account with School Center, visit http://www.schoolcenter.com for more information.



Posting Grades Online Using TeacherWeb®

TeacherWeb® provides individual teachers with an easy way to post assignments, announcements,
and other educational materials online. You can also post grades online so students and parents can
easily check progress.

To post grades online using TeacherWeb®, choose Export to TeacherWeb® from the File menu. The
standard save dialog will appear. Choose where you want to save the text file and click Save. This
will create a text file that you can then upload to TeacherWeb®.

Students must have an ID to be included in the export to TeacherWeb®.

You must have an account with TeacherWeb® to post grades there. If you do not have an account
with TeacherWeb®, visit http://www.teacherweb.com for more information.



Posting Grades Online Using The Homework Site

The Homework Site allows you to post grades, homework assignments, and other school activity
information online, allowing parents and students easy and secure access to that information.

To post grades online using The Homework Site, Choose Export to The Homework Site from the File
menu. The Export to The Homework Site dialog will appear:

Enter the class ID for this class, your username, and your password, then click OK. Your progress
reports will be sent to The Homework Site. Parents and students can then access all their grades
using their own username and password.

Students must have an ID to be included in the export to The Homework Site.

You must have an account with The Homework Site to post grades there. If you do not have an
account with The Homework Site, visit http://www.thehomeworksite.com for more information.



Gradekeeper Palm Application

The Gradekeeper Palm application works with Gradekeeper to allow you to take attendance, edit
scores and comments, and add new assignments using your Palm handheld. It is not a substitute for
your desktop copy of Gradekeeper.

Before you begin using the Gradekeeper Palm application, you must install the application onto your
Palm handheld. To install the application, launch the Palm Desktop software:

• Click the Install tool
• Click the Add button
• Choose Gradekeeper.prc
• Click the Open button

Gradekeeper.prc is located in the Gradekeeper folder in the Program Files folder in Local Disk (C:) in
My Computer.

Next, you must enable HotSync for each class you want to use on your Palm handheld. Open each
class with Gradekeeper, and choose Enable HotSync from the File menu. Finally, you must HotSync
your Palm handheld. This will copy the application and classes to your handheld.

When you run the Gradekeeper Palm application, you will see the students view:

You can choose another class by tapping the class name and choosing a class from the menu that
appears. You can choose another student by tapping the student name and choosing a student from
the menu that appears.

To edit a score, tap it and enter a new score. To add a footnote to a score, tap the footnote number
(or dash, if there is no footnote for that score) and choose the footnote you want from the menu that
appears.



To edit a student comment, tap the “i” button to the right of the student name. The student info form
will appear:

The student, their comment, and their grade at the time of the last HotSync are displayed. To enter a
comment, tap the comments field and enter your comment. Student comments can be up to 250
characters in length.

You can choose the assignments view by tapping the Assign push button.



You can edit scores and footnotes in the assignments view in the same way you can in the students
view. You can edit an existing assignment by tapping the “i” button. You can add a new assignment
by tapping the “+” button. Both buttons will show the assignment info form:

The assignment info form allows you to change the date, name, category, and points possible for an
assignment. You cannot change the date or name for an assignment after you do a HotSync. Those
items are used to match assignments on the handheld with assignments in the desktop class.

You can choose the attendance view by tapping the Attend push button.

When you choose the attendance view, today’s date is added to the database. You can also choose
earlier dates by tapping the date and choosing a date from the menu that appears. Only dates since
your last HotSync are available.

To choose an attendance code for a student, tap the code (or the dash, if there is no attendance code
for that student) and choose a code from the menu that appears.



The HotSync Process

When you HotSync, the Gradekeeper conduit does the following:

• Copies all changes and new assignments from the handheld to the desktop
• Copies all students, recent assignments, and today’s attendance to the handheld

The Gradekeeper conduit matches students by name and ID. Both must be equal for the student to
be considered a match. The conduit matches assignments by name and date. Both must be equal for
the assignment to be considered a match. The conduit matches classes by the date and time it was
first created.

The Gradekeeper conduit copies changed scores from the handheld to the desktop before it copies
scores from the desktop to the handheld. Changed scores on the handheld will always overwrite any
changed scores on the desktop.

This works quite well, and you will usually not even need to think about how the Gradekeeper conduit
does its business. But to avoid losing information you added on your handheld, you should follow
these suggestions:

• Do not change student names or IDs on the desktop
• Do not change assignment names or dates on the desktop
• Do not move, copy, or rename a class when HotSync is enabled
• Leave enough unused columns in the class for any new assignments
• Do not change scores for an assignment on the desktop and the handheld

If you need to change a student name or ID, or an assignment name or date:

• HotSync your Palm handheld
• Make the changes to the desktop class
• HotSync your Palm handheld again

If you need to move, copy, or rename a class:

• HotSync your Palm handheld
• Disable HotSync for that class
• Move, copy, or rename the class
• Enable HotSync for that class
• HotSync your Palm handheld



Gradekeeper Pocket PC Application

The Gradekeeper Pocket PC application works with Gradekeeper to allow you to take attendance,
edit scores and comments, and add new assignments using your Pocket PC. It is not a substitute for
your desktop copy of Gradekeeper.

To install the Gradekeeper Pocket PC application:

• Connect your Pocket PC to your desktop computer
• Click Start, then Programs, then Gradekeeper, then Install Pocket PC Application

If you already have an earlier version of Gradekeeper installed on your Pocket PC, you will need to
force it to quit before reinstalling. Pocket PC applications do not quit when you close them. They run
in the background. To quit Gradekeeper, show the keyboard by tapping the keyboard icon on the
lower right. Tap Ctl then tap q.

You can manually copy your classes between your Pocket PC and your desktop computer, much as
you would copy classes between a USB flash drive and your desktop computer. To copy classes to
your Pocket PC, open the Mobile Computer icon in My Computer. You should copy your classes into
the Personal folder.

You can also set up ActiveSync to automatically synchronize your classes:

• Start ActiveSync
• Click the Options button
• Choose the Sync Options tab
• Check the Files item in the list
• Choose the Rules tab
• Choose “Leave the item unresolved”

ActiveSync will create a special My Documents folder on your desktop. Any classes you want to
synchronize must be in this folder. When ActiveSync synchronizes, any changed classes will replace
the corresponding unchanged classes.

Classes must be in the same relative location in both the special My Documents folder and on your
Pocket PC. You should synchronize once before moving any classes into the special folder and then
copy them into the Personal folder.

Since ActiveSync file synchronization is for the entire file, you should not make changes to the same
class on both your Pocket PC and on your desktop computer. Make changes to one and synchronize
before making changes to the other.

When you start the Gradekeeper Pocket PC application, you will see the documents list. It will list all
classes on your Pocket PC. Tap the class you want to open. To close a class, tap the OK button. The
class will be saved automatically.



Classes open in the By Student view. You can choose the By Assignment view or the By Date view
from the View menu. The By Student view shows one student, their current grade, and their scores
on all assignments in the current term. Use the scroll bar at the bottom of the window to choose other
students.

To change a score, tap it and enter a new score. To add a footnote to a score, tap and hold on the
score. A menu will appear. Choose a footnote from the menu. To add comments about the student,
tap the student’s name. The comments dialog will appear:

Enter your comment in the comments field. Comments can be up to 255 characters long. Tap OK
when you are done.



The By Assignment view shows one assignment, its points possible, and scores for each student in
the class. Use the scroll bar at the bottom of the window to choose other assignments.

As in the By Student view, to edit a score, tap it and enter a new score. To add a footnote to a score,
tap and hold on the score. A menu will appear. Choose a footnote from the menu.

To edit an assignment’s date, name, category, or points possible, tap on the assignment name. The
edit assignment dialog will appear:

Choose a date by tapping the date and choose a new date from the calendar. Choose a category by
tapping the category and choosing a new category from the list. If you change the points possible, the
program will offer to scale the scores for this assignment.



The By Date view shows the current date and student attendance for that date. Use the scroll bar at
the bottom of the window to choose another date.

To take attendance for a student, tap and hold on that student. A menu will appear. Choose a code
from the menu. You can choose another term in the school year by choosing it from the View menu.

You can change the school, subject, or teacher for a class by tapping the subject in any view. The
subject dialog will appear:

Enter the school, subject, and teacher. Tap OK when you are done.



Opening Windows Classes

Gradekeeper is available for both Macintosh and Windows. You can easily open classes created on a
Windows computer on a Macintosh computer if you follow a few simple steps.

If you create a class on a Macintosh computer which you might want to use on a Windows computer,
include the ".grk" file extension. This allows the Windows version of Gradekeeper to recognize the file
as a Gradekeeper class.

If you want to use classes created by the Windows version of Gradekeeper on a Macintosh running
Mac OS 8.x or 9.x, you will need to use the File Exchange control panel (called PC Exchange in Mac
OS 8 and earlier). The File Exchange control panel lists Windows file extensions recognized by your
Macintosh:

To add the file extension used by the Windows version of Gradekeeper, click the Add button.



The Add Mapping dialog will be displayed, allowing you to add the appropriate extension:

Enter "grk" as the extension. Locate Gradekeeper from the list of applications and select it. Then
choose the GRCL document type from the pop-up menu. Then click Add. Then close the File
Exchange control panel.

Now, whenever you bring a class created under Windows to your Macintosh, it will display the same
icon as a class created on your Macintosh. Double clicking that icon will open the class with
Gradekeeper. All you need to do is make sure the class has the ".grk" extension.



If you want to use classes created by the Windows version of Gradekeeper under Mac OS X, you
may need to explicitly specify which application should open the class. Click once on the class icon,
then choose Get Info from the File menu:

Click the triangle to the left of Open with. This will display the Open with options. From the pop-up
menu, choose Other.



The Add Application dialog will be displayed, allowing you to specify the application:

Choose All Applications from the Show pop-up menu, navigate and find the Gradekeeper application
and select it. Check Always Open With. Click Add. Now, when you double click this class icon, it will
be opened using Gradekeeper. In the Get Info window, click Change All to apply this choice to all
Gradekeeper classes.

You can also use the Gradekeeper PC->Mac Applescript applet in the Gradekeeper folder to convert
Windows classes. Drag a class onto the Gradekeeper PC->Mac icon. The class will be converted to a
Macintosh class.



When You Make Mistakes

If you make a mistake or change something in a way you did not intend to, you may be able to cancel
that change. Choose Undo from the Edit menu. This will restore the gradebook to the way it was
before your last action.

Only your most recent action can be undone. If you cut a student from one class and paste that
student into another class, only the paste can be undone. There are also a few actions that cannot be
undone.

Making Backups

While Gradekeeper has proven very reliable, floppies are easily damaged and hard drives have been
known to fail. To avoid the risk of losing your grades at the worst possible time you should always
keep a current backup of your data on another disk.

To backup your classes:

• Insert a floppy disk into your disk drive
• Click the right mouse button on each class
• Choose Send To from the pop-up menu that appears
• Choose 3 1/2 Floppy from the sub-menu that appears

This will copy that class to the floppy disk. I also encourage you to keep paper copies of your
gradebook grid. This will allow you to reconstruct your grades if you should ever lose your data and
your backups.

Curving an Assignment

Curving an assignment means adjusting student scores on that assignment to fit the distribution of
grades you want. This is usually done to compensate when an assignment was more challenging
than expected.

You can curve an assignment by changing its points possible.

First, change the points possible for the assignment to a value that best reflects how students actually
did on the assignment. You may want to choose a value that is about the same as the highest score
earned on that assignment. When the program offers to scale student scores, click No.

Next, change the points possible for the assignment back to the original value. When the program
offers to scale student scores, click Yes. This will scale the student scores proportionally.



Grade Computation

Gradekeeper normally determines grades using total points earned. For every student, the sum of
their points earned is divided by the total points possible. This result is converted to the nearest tenth
of a percent. This percent is then used to determine a letter grade based on the current letter grade
percents.

Extra credit assignments (assignments in the Extra Credit category or assignments with 0 points
possible) contribute to each student’s points earned, but do not contribute to the total points possible.

For example:

It All Adds Up   7/ 10
Orient Express  10/ 10
Bulgarian Solitaire   8/ 10
Spirograph Special   8/ 10
Extra Credit Work  10/  0
Chapter 1 Homework  25/ 35
Chapter 1 Test  73/100

Total 141/175  =  80.6%

If you want certain kinds of assignments (such as tests or homework) to contribute a fixed amount to
each student’s grade, then you should compute grades using category weights. The percent correct
within each category will be computed, with grades being determined by a weighted average of the
percent correct within each category.

Extra credit assignments can affect grades in different ways when you are computing grade using
category weights.

Assignments with 0 points possible improve the percent correct within that category. If you place an
assignment with 0 points possible in the homework category, this would increase the percent correct
in that category for students earning points on that assignment.

Assignments in the Extra Credit category are treated like assignments in any other category. The
percent correct on these assignments is multiplied by the category weight. But the Extra Credit
category weight is not included when category weights are totaled.

The weight you choose for the Extra Credit category determines how much your extra credit
assignments will contribute to term grades, relative to your other categories. If you choose a weight of
10 for Extra Credit, and the total of the weights of your other categories is 100, any student with a
perfect score on every assignment would earn a grade of 110% for the term.



You should not put assignments with 0 points possible into the Extra Credit category. This would
make it possible for a student to earn more than 100% on extra credit assignments, and could result
in those assignments making no contribution to the grade. Gradekeeper will warn you if you give an
extra credit assignment 0 points possible.

The following is a detailed example of grade computation using category weights when you have
extra credit assignments:

Tests Chapter 1 Test  82/100
Chapter 2 Test  80/100
Chapter 3 Test  78/100

Total 240/300 = 80%

Homework Chapter 1 Homework  30/ 40
Chapter 2 Homework  20/ 30
Chapter 3 Homework  40/ 50

Total  90/120 = 75%

Activities Spirolaterals   8/ 10
Spirograph Special   7/ 10

Total  15/ 20 = 75%

Extra Credit Math Counts #1   7/ 10
Math Counts #2   3/ 10

Total  10/ 20 = 50%

Tests 80% correct  x  50 weight  =  40.0%
Homework  75% correct  x  30 weight  =  22.5%
Activities 75% correct  x  20 weight  =  15.0%
Extra Credit  50% correct  x  10 weight  =   5.0%

Total      100 weight  =  82.5%

Without the assignments in the Extra Credit category, this student would have earned a grade of
77.5% for the term. Note that the Extra Credit category is not included when the category weights are
totaled. This is what makes these assignments truly extra credit.



Semester grades are computed by averaging term grades. Final grades for the year are computed by
averaging semester or trimester grades. All averaging is done using percents.

For example:

1st Quarter     81%
2nd Quarter     75%
3rd Quarter     82%
4th Quarter     86%

1st Semester    (81% + 75%) ÷ 2 = 78%
2nd Semester    (82% + 86%) ÷ 2 = 84%

Final           (78% + 84%) ÷ 2 = 81%

Grade computation includes final exam grades as specified in your school year options. For example,
if final exams are 30% of the term grade, and a student earned 75% on the exam:

Term Grade      81% x 70 = 56.7
Final Exam      75% x 30 = 22.5

Grade (including Exam)     79.2%

If final exams are 20% of the semester grade, and a student earned 72% on the exam:

Semester Grade  78% x 80 = 62.4
Final Exam      72% x 20 = 14.4

Grade (including Exam)     76.8%

You may choose different categories, weights, and grading options for each term in the school year.
This gives you the flexibility to change how you compute grades during the course of the school year.



Paying for Gradekeeper

Gradekeeper is not free. You may try Gradekeeper for 30 days. If you decide to continue using it, you
must pay for it. When you pay, you will receive a registration code that will eliminate those reminders
to pay. This registration code will also allow you to use future versions of Gradekeeper at no
additional cost.

A single license is $20 and allows you to use Gradekeeper. A school license is $100 and allows every
teacher at your school to use Gradekeeper. A district license is $500 and allows every teacher in your
school district to use Gradekeeper. All licenses allow the use of Macintosh and Windows versions of
Gradekeeper both at home and at school.
 
You can pay for Gradekeeper online at http://www.gradekeeper.com/purchase.htm using your credit
card and receive your registration code in minutes. The registration web page is on a secure server to
protect your credit card number and your personal information.
 
To pay for Gradekeeper by phone, call Register Now toll free at 877-353-7297. You will receive your
registration code during the phone call. There is a $3.00 processing charge for phone orders.
 
To pay for Gradekeeper using a purchase order, visit http://www.gradekeeper.com/purchase.htm and
choose the license you want. Complete the online order form, choosing the purchase order payment
method. You will be given an order number and directions for faxing or mailing your purchase order to
Register Now.

Your purchase order must be made payable to Register Now. Payment terms must be payable upon
receipt. Please do not make your check or purchase order payable to Gradekeeper. Please include
your order number on your purchase order to avoid any delays in receiving your registration code.

There is a $10.00 processing charge for all purchase orders. You will receive your registration code
by e-mail when Register Now receives your payment.



Programmer’s Notes

I wrote Gradekeeper because I was unable to find an inexpensive grading program that had the
features I wanted and was also easy to use. I hope Gradekeeper will fill that void for you as well.

Special thanks to my fellow teachers for their many comments and suggestions, which have helped
make Gradekeeper so friendly and powerful. Your comments and suggestions are also appreciated.
You can reach me at:

info@gradekeeper.com

For more information and the latest version of Gradekeeper, visit my web site at:

http://www.gradekeeper.com/


